Wie deaktiviere ich den Suspend-Modus?

  • Immer wenn ich meinen Raspberry Pi über Nacht stehen lasse, scheint er immer in eine Art Schwebezustand getreten zu sein. Die rote Betriebsanzeige leuchtet noch, aber die LED am USB-WLAN-Gerät ist aus und ich kann mit SSH nicht darauf zugreifen.

    Ich habe keine Peripheriegeräte angeschlossen, außer einem USB-WLAN Gerät. Ich benutze es einfach kopflos als Audioplayer.

    Wer weiß, wie man Suspend-Funktionen vollständig deaktiviert?

    01 August 2012
    ppumkin
4 answers
  • Sie haben nicht viele Details angegeben, aber ich gehe davon aus, dass Sie einen WLAN-Adapter mit dem Realtek 8192cu-Chip verwenden, da dies häufig verwendet wird. Mein ist das Gleiche, und ich habe erfahren, was ich denke, ist das gleiche Problem: Wenn Sie das RPi längere Zeit im Leerlauf lassen, scheint das WLAN deaktiviert zu sein und Sie können keine Verbindung mehr über SSH herstellen.

    Ich habe seit Monaten nach einer Lösung dafür gesucht und hier gerade erst eine gefunden: https://github.com/xbianonpi/xbian/issues/217 . Die Lösung ist für xbian, aber für Raspbian hat es funktioniert.

    Das Problem scheint zu sein, dass der Adapter standardmäßig über Energieverwaltungsfunktionen verfügt. Dies kann durch Ausführen des Befehls überprüft werden:

     cat /sys/module/8192cu/parameters/rtw_power_mgnt
     

    Ein Wert von 0 bedeutet deaktiviert, 1 bedeutet min. Power Management, 2 bedeutet max. Energieverwaltung. Um dies zu deaktivieren, müssen Sie eine neue Datei erstellen:

     sudo nano /etc/modprobe.d/8192cu.conf
     

    und fügen Sie Folgendes hinzu:

     # Disable power management
    options 8192cu rtw_power_mgnt=0
     

    Wenn Sie die Datei speichern und Ihr RPi neu starten, sollte das WLAN auf unbestimmte Zeit eingeschaltet bleiben.

    17 December 2016
    techrafHerohtar
  • Die bevorzugte Antwort scheint nahezu korrekt zu sein, jedoch einige zusätzliche Kommentare in der ursprünglichen Ausgabe () https://github.com/xbianonpi/xbian/issues/217 ) würde vorschlagen, dass eine zusätzliche Option besser ist:

    options 8192cu rtw_power_mgnt=0 rtw_enusbss=0

    in /etc/modprobe.d/8192.conf, im Gegensatz zu nur rtw_power_mgnt=0. Einfach zu spezifizieren, dass eine Option für mich nicht funktioniert hat, da sich das WLAN immer noch ausgeschaltet hat.

    18 November 2014
    Talos
  • Mein Problem war der Bildschirmschoner. Deaktivieren Sie die folgenden Befehle:

    Damit wird der Bildschirmschoner deaktiviert:

     xset s off
     

    Deaktivieren Sie andere Energy Star-Funktionen:

     xset -dpms
     

    Dies wird nicht in einer Remote-SSH-Sitzung arbeiten

    30 July 2013
    Dan Power
  • GDM

    Sie können verhindern, dass GDM Ihren Computer unterbricht, indem Sie einen Wert in dconf-editor ändern. Beachten Sie, dass ich dconf-editor, nicht gconf-editor.

     $ dconf-editor
     

    jetzt müssen Sie zum Knoten org.gnome.settings-daemon.plugins.power navigieren. Sie sollten eine vollständige Liste von Schlüssel-Wert-Paaren sehen. Ändern Sie die folgenden Schlüssel in die folgenden Werte:

    • sleep-inactive-ac-type in nichts
    • sleep-inactive-battery-type an nichts

    Referenzen

    01 August 2012