Funktioniert der Filter für ältere IE-Versionen?

  • Ich habe die folgende Codezeile in meinem Programm:

     $('input').filter(':radio').change(function() {
     

    Das Problem ist, dass einige Leute, die Internet Explorer verwenden, angegeben haben, dass sie nicht starten (oder die darin enthaltene Routine nicht funktioniert). Ich weiß, dass JavaScript für ihren Browser aktiviert ist, da andere Dinge funktionieren.

    Gibt es ein bekanntes Kompatibilitätsproblem mit IE und dem oben genannten Code? Ich habe IE9 und es funktioniert für mich. Ich lade die neueste Version von jQuery von Googles CDN.

    22 November 2011
    Phillip Senn
1 answer
  • Sie haben von keinem bekannten Problem gehört, Sie können es jedoch auch ohne Filter schreiben:

     $('input:radio').change(function() {
      // your code
    });
     
    22 November 2011
    Strelok